FAQ

Как установить Eclipse IDE на Ubuntu 11.10

Интегрированные среды разработки (IDE) предоставляет очень удобный способ разработки софта, потому что они автоматизируют множество скучных/трудных задач. Хотя некоторые программисты предпочитают не использовать никаких IDE (особенно ruby-программеры – они используют TextMate или gedit, или другие текстовые редакторы), но java-программисты используют IDE в большинстве случаев, потому что наличие IDE делает многие задачи намного легче. Это означает, что необходимость IDE также зависит от типа языка программирования или сложности проекта. Так как Java основан на парадигме "конфигурация как обыкновение", так что IDE является "must have"-инструментом (для Java-разработчиков) для автоматизирования многих задач, освобождая время для кодинга актуальных вещей.

Ubuntu (последняя версия - 11.10) стал самым популярным настольным Linux-дистрибутивом и имеет хорошую репутацию у программистов, особенно у java-программистов. Ничто так быстро не набирает популярность, даже корейские авто. Так как eclipse - лучшая IDE для java – множество java-программистов используют Ubuntu как ихнюю платформу разработки, так что этот пост поможет начинающим программистам начать работу с Ubuntu с Eclipse IDE. Eclipse - самый популярный IDE, не только для java, но также для других объектно-ориентированных языков программирования, таких как C/C++, PHP, JavaScript, Ruby on Rails (плагин Aptana доступен для Eclipse). Плагин Google Android SDK также доступен для Eclipse IDE – что делает Eclipse очень популярным в разработке приложений для смартфонов, особенно для Android-девайсов. У него множество доступных свободных плагинов, чтобы использовать те возможности, которые вам нужны.

eclipse-ubuntu-11-10

Устанавливаем Eclipse IDE на Ubuntu 11.10 (Oneiric Ocelot)

Откройте терминал (можно нажать на клавиатуре Ctrl+Alt+t) и выполинте -

sudo apt-get install eclipse

После того, как вы установили платформу eclipse и её зависимости, вы можете установить требуемые пакеты/плагины для вашей работы.

Например, если вы java-разработчик, установите JDT (Java Development Tools), используя команду -

sudo apt-get install eclipse-jdt

для программирования на C/C++, установите плагин CDT,

sudo apt-get install eclipse-cdt

или вы можете просто поискать в Центре приложений Ubuntu и установить нужный плагин оттуда.

installing-eclipse

Добавить комментарий


Защитный код
Обновить

Аккаунт



Подпишись на нашу RSS

Go to top