Новости

Вышел лаунчер Synapse 0.2.8 с новой темой

Synapse — семантический лаунчер наподобие Gnome Do или Kupfer, использующий сервис Zeitgeist. Он поставляется с рядом плагинов, позволяющих управлять плеерами Rhythmbox или Banshee, подключаться к хостам по SSH-протоколу, загружать картинки на Imgur, заниматься серфингом и т.д.

b_675_675_16777215_10_images_stories_201110_synapse_0.2.8.png

Вызывается Synapse комбинацией Ctrl + Space (по умолчанию). По мере набора, Synapse будет показывать соответствующие набранному тексту программы, сортируя приложения по частоте обращения. При нажатии при выделении файла клавиши TAB, вы можете выбрать действие: копировать в буфер, запустить приложение и т.д.

В последней версии 2.8 лаунчера Synapse появилась новая тема Side Doish, категория Places и плагин Related Files (похожие файлы). Пользовательский интерфейс полностью поменялся.

Вот несколько скриншотов:

b_675_675_16777215_10_images_stories_201110_synapse_side-doish.png

(Тема Side Doish - цвета берутся из текущей темы GTK)

b_675_675_16777215_10_images_stories_201110_synapse_places.png

(Новая категория Places)

b_675_675_16777215_10_images_stories_201110_synapse_related.png

(Плагин Find Related (найти похожие))

Другие изменения в Synapse 0.2.8 включают: более быструю прорисовку и меньшее время запуска, оптимизированный поиск с использованием движка Zeitgeist и исправление багов метода ввода IBus и плагина SSH. Эти функции были и в предыдущих, сырых версиях Synapse, но теперь они стали доступны тем, кто предпочитает PPA со стабильно работающим релизом.

Что дальше?

В блоге Альберто, одного из разработчиков, опубликована информация о появлении в следующей версии Synapse (0.3.0) поддержки GTK 3, плагина клиента обмена сообщениями, комплексных действий (наподобие файл > переместить > папка) и других.

Установка Synapse в Ubuntu

Для добавления PPA-репозитория и установки последнего Synapse 0.2.8 в Ubuntu версий 10.04, 10.10 или 11.04 используйте нижеприведенные команды:

sudo add-apt-repository ppa:synapse-core/ppa
sudo apt-get update
sudo apt-get install synapse

 

К сожалению, Synapse 0.2.8 не работает в Ubuntu 11.10 Oneiric Ocelot, но есть надежда на скорое исправление бага.

Если Вы хотите заранее подготовить поздравления с новым годом подруге, советуем посетить сайт greets.ru.

Добавить комментарий


Защитный код
Обновить

Аккаунт



Подпишись на нашу RSS

Go to top